JavaFX SDK en Eclipse

JavaFX es un nuevo lenguaje de Scripts diseñado por Sun Microsystems. El objetivo de este nuevo lenguaje, (mezcla de C y Java, según mi opinión) es ocupar el lugar que ya tiene Flash en el mercado de las RIAs (Rich Internet Applications) y además adaptarse a los nuevos dispositivos móviles, gracias a su versión JavaFX mobile. Ya se dio la noticia del lanzamiento en Java-Spain, pero ahora quería profundizar un poco en su tecnología y los primeros pasos que debemos dar para empezar a conocerlo.

Lo primero de todo es descargar el JavaFX SDK. Yo voy a optar por instalar un plugin para Eclipse, pero en la misma página de descargas tenéis una versión para NetBeans. Si, como es mi caso, vais a instalarlo en Eclipse, será necesario descargar sólo el SDK desde la página de descargas de JavaFX y a continuación abrir Eclipse.

Una vez que tenemos Eclipse abierto, sólo tenemos que utilizar la herramienta de actualizaciones e introducir el siguiente sitio:

http://download.java.net/general/javafx/eclipse/{Sistema Operativo}/site.xml

Sistema Operativo ⇒ windows | linux | macosx

pulsar en instalar y listo. Ahora queda lo más divertido, aprender a programar con JavaFX.

Lo podéis ver en vídeo:

Sin votos aún

tengo problemas con las varialbes de entorno, yo tambien soy usuario de mac, si me puedes ayudar, gracias

En un post anterior, http://java-spain.com/instalando-la-java-virtual-machine, se explica cómo instalar la JVM y además a configurar las variables de entorno. Si aun así no lo consigues, deja un comentario en esa entrada, por si alguien tiene la misma duda que esté más a mano.
Un saludo.

No lo pude instalar me estoy rompiendo la cabeza y no encaro :@
hice lo q decis ahi pero me dice :JavaFX Feature (1.0.1) requires plug-in "org.apache.ant (1.7.0)", or later version.
y no se como instalarlo me estoy volviendo loco intentando instalar eso lo baje ya y lo he paseado por todas las carpetas q pude tmb me meti en los menus del eclipse a ver si me dejaba incluirlo de alguna manera pero no puedo :(
Por favor si sabes como resolverlo t agradeceria en el alma q me lo contaras, te dejo mi mail.

SAludos y muchas gracias

@penque
Has intentado actualizar Eclipse a la nueva versión 3.5? Si no lo has intentado, añade http://download.eclipse.org/eclipse/updates/3.5 a la lista de sitios en la herramienta de actualizaciones.

Si aún así no lo consigues, deja otro comentario.